Issue installing VS2015RC on certain VMs (Visual C++ Redistributable for Visual Studio 2015 RC fails on Windows Server 2012)

I’m currently encountering issues with installing VS2015RC on some VMs that I have on hand (W2K12 upgraded to W2K12R2), as TFS XAML builds are not able to succeed without the presence of VS2015RC on them.  Symptoms of the errors I encounter include:

  1. Access Denied on various components during the installation
  2. Errors logged in installation log file

[1E58:06CC][2015-05-26T15:07:39]i301: Applying execute package: Windows81_x64, action: Install, path: C:\ProgramData\Package Cache\469A82B09E217DDCF849181A586DF1C97C0C5C85\packages\Patch\x86\Windows8.1-KB2999226-x64.msu, arguments: ‘”C:\Windows\SysNative\wusa.exe” “C:\ProgramData\Package Cache\469A82B09E217DDCF849181A586DF1C97C0C5C85\packages\Patch\x86\Windows8.1-KB2999226-x64.msu” /quiet /norestart’

[1E58:06CC][2015-05-26T15:07:39]e000: Error 0x80070005: Failed to open WU service.

[1E58:06CC][2015-05-26T15:07:39]e000: Error 0x80070005: Failed to ensure WU service was enabled to install MSU package.

[1E58:06CC][2015-05-26T15:07:39]e000: Error 0x80070005: Failed to execute MSU package.

[091C:14C8][2015-05-26T15:07:39]e000: Error 0x80070005: Failed to configure per-machine MSU package.

[091C:14C8][2015-05-26T15:07:39]i000: MUX:  Installation size in bytes for package: Windows81_x64 MaxAppDrive: 0  MaxSysDrive: 0  AppDrive: 0  SysDrive: 0

Managed to manually install the offending patch, but even after that, the installation still fails. (Thanks @sihuiwsh)

Apparently others have also encountered this problem, will keep an eye out and update here if a solution is found.(https://social.msdn.microsoft.com/Forums/en-US/64baed8c-b00c-40d5-b19a-99b26a11516e/visual-c-redistributable-for-visual-studio-2015-rc-fails-on-windows-server-2012?forum=vssetup&prof=required)

Advertisements

One response to “Issue installing VS2015RC on certain VMs (Visual C++ Redistributable for Visual Studio 2015 RC fails on Windows Server 2012)

  1. Pingback: XAML Build fails in TFS 2015 RC: Could not load file or assembly ‘Microsoft.Build.Utilities.Core, Version=14.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a’ or one of its dependencies. | Zonghe's Blog

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s